Ac vacuum switch

Discussion in 'General Ranchero Help' started by Ran Man, Mar 6, 2024.

  1. Ran Man

    Ran Man In Fourth Gear

    Messages:
    336
    Does anyone know if afaulty switch can cause air not to blow through your ac vents?

    I changed the actuator today with no luck on fixing the issue.

    The air comes through the floor and defrost just fine.
     
  2. thebruins

    thebruins In Third Gear

    Messages:
    185
    Check out the diagram below. It's for a '79 but I'm assuming it's more or less the same for other years.
    I guess the actuator is not getting any vacuum, so perhaps a broken hose or a faulty switch? (defrost is default when the switch has little or no vacuum)



    [​IMG]
     
  3. Ran Man

    Ran Man In Fourth Gear

    Messages:
    336
    Thank you Bruin for the info
     
  4. 1979 RANCHERO GT

    1979 RANCHERO GT In Maximum Overdrive

    Messages:
    1,108
    Did you get both vacuum plugs plugged in, the 3 port upper and the lower 9 port ? The upper one is easy to forget. I forgot the upper one, fortunately only had to get the cluster back off (the worst part to remove). If you find some controllers in wrecking yards they are worth picking up, I drove with a broken one for a year before finding one. Somebody is going to need one.
     
  5. 1978GT

    1978GT In Overdrive GOLD MEMBER

    Messages:
    626
    NOS units come up on eBay from time to time. About a year ago I snagged both for under $25 total shipped. Good spares to have on hand.

    AC Vacuum Switch a.jpg

    AC Vacuum Switch b.jpg
     
  6. Ran Man

    Ran Man In Fourth Gear

    Messages:
    336
    Very nice
     
  7. The Wrench

    The Wrench In Second Gear

    Messages:
    85
    Ran Man, you may have already checked this but have you checked the vacuum reserve can under the hood ? it's either mounted to the firewall or on one of the fenders under the hood, that can has a one way valve that makes it hold vacuum for the system. If you haven't checked it you should. The Wrench
     
  8. Ran Man

    Ran Man In Fourth Gear

    Messages:
    336
    I did check that and it held vacuum. Everything works as it should except for the AC. Defrost, floor, vent all work perfect. I checked to see if any vacuum hoses were cracked but didn't find anything. I also put on a new actuator that controls the door. I am not sure where to go from here.
     
  9. Ran Man

    Ran Man In Fourth Gear

    Messages:
    336
    I did get both sets plugged in
     
  10. 1978GT

    1978GT In Overdrive GOLD MEMBER

    Messages:
    626
    Based on that, the fault is at Door 6 (A/C Heat Door). Take a closer look at the diagram and chart at post #2 by thebruins. You should be able to figure out the problem.
     
  11. Ran Man

    Ran Man In Fourth Gear

    Messages:
    336
    You would think I should but I haven't yet.
     
  12. 1978GT

    1978GT In Overdrive GOLD MEMBER

    Messages:
    626
    Pull the hose from the actuator and check for vacuum, either full or partial depending on the switch position (see chart). No vacuum = bad switch, vacuum = bad actuator, actuator not connected to door, or door stuck shut.
     

Share This Page