Accelerator linkage and cable problems

Discussion in 'New Member Welcome Center' started by Tool hoarder, Mar 25, 2020.

  1. Tool hoarder

    Tool hoarder In First Gear

    Messages:
    2
    I inherited a 69 Ranchero 250 6 cyl C4 automatic that has sat for many years. Having fun fixing modifications by previous owner. Not sure if I have the correct accelerator cable as it’s too long maybe an 1 1/2. Questioning linkage and brackets. Would love to see pictures of working examples.
     
  2. PonyExpressRider

    PonyExpressRider In Maximum Overdrive

    Messages:
    1,018
    Location:
    Sutherlin, OR
    Congrats on the inherit, sorry for your loss!

    Since you are having issues with the throttle cable, you may want to see if the throttle assembly has been replaced. My 69, with a V8 uses linkage from the throttle to the throttle body. sorry, no pics.

    upload_2020-3-25_23-12-41.png
    upload_2020-3-25_23-11-44.png
     
  3. PonyExpressRider

    PonyExpressRider In Maximum Overdrive

    Messages:
    1,018
    Location:
    Sutherlin, OR
    this should be your carb:

    upload_2020-3-25_23-16-57.png
     
  4. PonyExpressRider

    PonyExpressRider In Maximum Overdrive

    Messages:
    1,018
    Location:
    Sutherlin, OR
    Looks like you should have linkage as well... C9OZ

    upload_2020-3-25_23-34-17.png

    upload_2020-3-25_23-34-37.png
     
  5. Tool hoarder

    Tool hoarder In First Gear

    Messages:
    2
    Thanks for your reply. I have bought 2 expensive NOS cables with 1969 part numbers approximately 31 inches long and The much shorter Mustang version which is reproduced. I have the correct autolite carburetor like your picture C9Oz yet something is still missing or not right.
     

Share This Page