Adding Fitech

Discussion in 'Ranchero Tech Reference & Articles' started by crab1, Oct 5, 2021.

  1. crab1

    crab1 In Second Gear

    Messages:
    40
    Getting ready to install fitech 35203 in the chero, waiting on some parts.
     
    Last edited: Oct 6, 2021
  2. crab1

    crab1 In Second Gear

    Messages:
    40
    IMG_05102021_125305_(800_x_480_pixel).png
    Return line into filler neck.
     
    andrewok1 and LSChero like this.
  3. Anton Olafsson

    Anton Olafsson In Second Gear

    Messages:
    33
    Location:
    Iceland
  4. crab1

    crab1 In Second Gear

    Messages:
    40
    Appreciate the input however, with the lack of efi tanks available for these cars and not wanting to have one custom made it will be just fine. I've done it this way in the past with no issues.
     
    Lincolnut likes this.
  5. RancheroRandy

    RancheroRandy In Overdrive

    Messages:
    958
    Location:
    NC
  6. crab1

    crab1 In Second Gear

    Messages:
    40
    IMG_07102021_051326_(480_x_800_pixel).jpg IMG_07102021_051339_(480_x_800_pixel).jpg
     
    LSChero likes this.
  7. handy_andy_cv64

    handy_andy_cv64 In Maximum Overdrive SILVER MEMBER

    Messages:
    12,133
    Location:
    Seguin, TX
    That's a neat little unit. Do you have specs or a linky?
     
  8. crab1

    crab1 In Second Gear

    Messages:
    40
    Last edited: Oct 7, 2021
  9. LSChero

    LSChero In Maximum Overdrive PLATINUM MEMBER

    Messages:
    2,400
    Location:
    Area 6 NV
    Slick setup!Will be waiting for review,once ya get her all dialed in.Is this on a windsor or cleveland engine Crab?
     
  10. crab1

    crab1 In Second Gear

    Messages:
    40
    351w, made a little progress tonight, bolted right up. Still sorting out how I'm running the low pressure feed and return line from the force fuel module.
    IMG_07102021_191151_(480_x_800_pixel).jpg IMG_07102021_191142_(480_x_800_pixel).jpg IMG_07102021_191131_(480_x_800_pixel).jpg
     
  11. handy_andy_cv64

    handy_andy_cv64 In Maximum Overdrive SILVER MEMBER

    Messages:
    12,133
    Location:
    Seguin, TX
    Oh, I was only asking about the Force Fuel module, but I found what info I needed, and that appears to be a slick little unit. It could work with EEC V system pressures. Just thinking out loud here.
     
  12. crab1

    crab1 In Second Gear

    Messages:
    40
    Under hood fuel lines.
     

    Attached Files:

  13. crab1

    crab1 In Second Gear

    Messages:
    40
    Another
     

    Attached Files:

  14. crab1

    crab1 In Second Gear

    Messages:
    40
    Monday night everything hooked up primed and ready so I turned the key on for 1 or 2 seconds. Pump energized, so after it was off I went to check for leaks and had a fine mist spraying from the high pressure filter. Discovered that it was machined wrong and the rings wouldn't seal, they are sending another. I was however able to substitute a slightly larger o-ring from my assortment kit and start the vehicle last night, started first time no leaks running 58-60 psi. Anxious for some decent weather to get it out and let it learn.
     
    LSChero and Kiwirancher like this.
  15. LSChero

    LSChero In Maximum Overdrive PLATINUM MEMBER

    Messages:
    2,400
    Location:
    Area 6 NV
    Progress is progress.Did the kit come with inertia switch?Good time to hide a kill toggle switch somewhere,just to slow em up a bit while you rack in a round.
     
  16. crab1

    crab1 In Second Gear

    Messages:
    40
    No but I like the idea! I'd probably put in a relay to the fuel pump.
     
    Last edited: Oct 14, 2021
  17. LSChero

    LSChero In Maximum Overdrive PLATINUM MEMBER

    Messages:
    2,400
    Location:
    Area 6 NV
    You can get inertia switch off any efi ford at yards.Look in trunk area.Mounted mine in cubby.
     
  18. crab1

    crab1 In Second Gear

    Messages:
    40
    First impressions are good, took a short drive last night maybe 3 miles. I will get a few pictures of my settings in real time.
     
  19. uk ranchero

    uk ranchero In Second Gear

    Messages:
    91
    had EFI fitted a few years now very pleased with it. i put the pump in the tank using a Tanks INC kit.
     
  20. crab1

    crab1 In Second Gear

    Messages:
    40
    Something happened on the way to work today about 15 miles from home broke down on the side of the freeway. For some reason I lost fuel pressure and after work today I'll do a little more troubleshooting, could be something simple but who knows... Up until that point it was running great and even the cold startup was almost perfect.
     

Share This Page