Spark plug diagnosis?1990 5.0 efi mass air

Discussion in 'Ranchero Tech Help' started by LSChero, Jan 20, 2019.

  1. LSChero

    LSChero In Maximum Overdrive PLATINUM MEMBER

    Messages:
    2,017
    Location:
    Area 6 NV
    Just rolled 1200 miles on 5.o efi build and little disappointed with performance.Getting 18 mpg average,but seems like motor wants more fuel/air?Do plugs look lean? All stock lower,addition of gt4o intake,alum. gt40 1.94,175 cfm X heads,headers.New o2s,tps.Was getting detination/popping noise in intake.Went to 91 oct and
    seems to have stopped.Runs smooth,no operating codes.This motor is a dog compared to 73 stock 5.0 with 130k!
    I do need to change rear gears(2.79) to 3.50 but damn its slow.
    SAM_4343.JPG
     
  2. andrewok1

    andrewok1 In Maximum Overdrive SILVER MEMBER GOLD MEMBER

    Messages:
    3,228
    Location:
    ocala ,florida
    This chart may help john.. lean look to me , i put 3:25 in my rear made a world of difference
    [​IMG]
     
    LSChero likes this.
  3. LSChero

    LSChero In Maximum Overdrive PLATINUM MEMBER

    Messages:
    2,017
    Location:
    Area 6 NV
    Yeh,thats what I was thinking.Had 19# CV 4 hole injectors in,put stock 19# squirters back in today.No improvement.Dont have gauge to check pump pressure.
    Could be weak,junk yard unit.May even go 3.73 with the driving I do here.
     
  4. handy_andy_cv64

    handy_andy_cv64 In Maximum Overdrive SILVER MEMBER

    Messages:
    8,353
    Location:
    Everett, WA
    The CV/Exploder 'thin' 4-hole injectors should be a fair improvement, but did you read the datastream, test O2 sensor bias by forcing rich/lean conditions, and does the exhaust have 1/2 to 1 PSI backpressure?
     
  5. LSChero

    LSChero In Maximum Overdrive PLATINUM MEMBER

    Messages:
    2,017
    Location:
    Area 6 NV
    Dont think OBD1 will run datastream Andy.If i had VSS hooked up,could run cyl balance KOER.Ran compression test when had plugs out,all good 160/165#.
    Went into town today and couldnt get it pop through intake,ran perfect.Had a shop check injector rail presser, good at constant 39 psi.Probably should have invested the 20$ in new gauge for MY tool box..Going to dump codes,drive for a while let it relearn.Hopefully sputter wont return.
     
  6. handy_andy_cv64

    handy_andy_cv64 In Maximum Overdrive SILVER MEMBER

    Messages:
    8,353
    Location:
    Everett, WA
    Ford EEC IV has datastream from '91. I seem to recall, yours was mid-'90s.
     
  7. handy_andy_cv64

    handy_andy_cv64 In Maximum Overdrive SILVER MEMBER

    Messages:
    8,353
    Location:
    Everett, WA
    Oops, I just noted the title of the thread. Which means break out the DVM and start manually checking the sensors one at a time.
     

Share This Page